Bug #917

F3_FLOW3_Package_ManagerTest shows 2 errors on WAMP installation

Added by David Bruehlmeier over 13 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
Package
Target version:
-
Start date:
2008-06-30
Due date:
% Done:

0%

Estimated time:
0.00 h
PHP Version:
Has patch:
Complexity:

Description

Hi,

I checked out the distribution from SVN as shown in the podcast. The default view is showing fine. When running the unit tests for the FLOW3 package, I get the following two errors:

F3_FLOW3_Package_ManagerTest
Failure in getPackagePathReturnsTheCorrectPathOfTheTestPackage Detail
D:\Entwicklung\Projekte\PHP\FLOW3\Packages\PHPUnit\Resources\PHP\PHPUnit\Framework\Assert.php:1524
getPackagePath() did not return the correct path for package "TestPackage". Failed asserting that <string:D:/Entwicklung/Projekte/PHP/FLOW3/Packages\TestPackage/> is equal to <string:D:/Entwicklung/Projekte/PHP/FLOW3/Packages/TestPackage/>. getPackagePath() did not return the correct path for package "TestPackage".
Failure in getPackageClassesPathReturnsClassesPathOfTestPackage Detail
D:\Entwicklung\Projekte\PHP\FLOW3\Packages\PHPUnit\Resources\PHP\PHPUnit\Framework\Assert.php:1524
getPackageClassesPath() did not return the correct path for package "TestPackage". Failed asserting that <string:D:/Entwicklung/Projekte/PHP/FLOW3/Packages\TestPackage/Classes/> is equal to <string:D:/Entwicklung/Projekte/PHP/FLOW3/Packages/TestPackage/Classes/>. getPackageClassesPath() did not return the correct path for package "TestPackage".
Tests: 6 total, 0 skipped, 0 incomplete, 2 failed, 0 errors

I have attached the phpinfo() so you can have a look at my installation (basically Windows XP with Apache 2.2.6 and PHP 5.2.4)

Greetings, Dave


Files

phpinfo.htm (59.5 KB) phpinfo.htm David Bruehlmeier, 2008-06-30 08:50

Related issues

Is duplicate of TYPO3.Flow - Bug #918: F3_FLOW3_Cache_Backend_FileTest shows 2 errors on WAMP installationResolvedBastian Waidelich2008-06-30

Actions
#1

Updated by Bastian Waidelich over 13 years ago

  • Status changed from New to Closed

Also available in: Atom PDF