Bug #91713

Wrong decision in SwitchViewHelper

Added by Daniel Koether about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2020-06-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Hello everyone,

I think there is a bug in the fluid ViewHelper f:switch. Let me explain it with the following example. This is the snippet to reproduce the misbehaviour.

<f:switch expression="3-non-slide">
    <f:case value="6">
            CASE 6
        </f:case>
        <f:case value="3">
            CASE 3
        </f:case>
        <f:case value="3-non-slide">
            CASE 3-non-slide
        </f:case>
        <f:case value="2-non-slide">
            CASE 2-non-slide
        </f:case>
        <f:case value="2">
            CASE 2
        </f:case>
        <f:case value="2-with-2-elements">
        CASE 2-with-2-elements
        </f:case>
</f:switch>

If I'm not doing something terribly wrong then the result should be "CASE 3-non-slide" but it is "CASE 3" instead.
Can somebody test the snippet above and confirm this bug? For simplicity there is no fluid variable in the expression attribute.

Thanks in advance!

#1

Updated by Chris Müller 12 months ago

I can confirm this for Fluid 2.6.9. However, the switch view helper is in the Fluid standalone package:
https://github.com/TYPO3/Fluid
So, there should be opened an issue.

#2

Updated by Daniel Koether 12 months ago

Chris Müller wrote:

I can confirm this for Fluid 2.6.9. However, the switch view helper is in the Fluid standalone package:
https://github.com/TYPO3/Fluid
So, there should be opened an issue.

Thank you Chris for confirming this bug! Since you spotted that this is a fluid bug I will create a bug report on github. This forge ticket can be closed :)

#3

Updated by Riccardo De Contardi 12 months ago

  • Status changed from New to Closed

Daniel Hinderink Koether thank you for your quick answer; I close this issue.

For reference, the issue on Github is https://github.com/TYPO3/Fluid/issues/520

If you think that this is the wrong decision, please reopen it or ping me.

#4

Updated by Riccardo De Contardi 12 months ago

  • Target version deleted (next-patchlevel)

Also available in: Atom PDF