Bug #9279

Optional arguments are not supported

Added by Robert Lemke over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
ExtDirect
Target version:
-
Start date:
2010-08-12
Due date:
% Done:

100%


Description

The ProviderViewHelper registers all controller actions which are annotated with @extdirect. For correct handling within ExtJS, the number of arguments for each action must be registered as well.

Now the problem is that the ProviderViewHelper just counts the number of arguments of a PHP method and uses this number as an argument count for ExtJS. If, however, an argument is optional and the client side doesn't define that argument, the communication between client and server through ExtDirect fails.

The solution, for now, is to just ignore optional arguments.

Associated revisions

Revision 92b61384 (diff)
Added by Robert Lemke over 9 years ago

[~TASK] ExtJS: Added doc comments to a few methods. Added basic parameter check for transaction arguments.
[+BUGFIX] ExtJS (ExtDirect): Fixed a bug which resulted in a broken communication between client and server via ExtDirect if a shared action method had optional arguments. Resolves #9279
[~TASK] FLOW3 (MVC): Cleaned up the code and documentation of the JsonView
[+FEATURE] FLOW3 (Persistence): The base repository now only sets the repository's object type if it has not been defined before. By that it is possible to define a custom object type in the property declaration of a concrete repository.
[+FEATURE] FLOW3 (Property): The property mapper now supports creation and recreation of objects specified by a UUID in an identity array even if they are just part of the overall source object / array to be mapped.
[+BUGFIX] FLOW3 (Validation): Fixed a few failing tests of composite validators, caused by incorrect mock building.

Change-Id: Iebe231298cc72fb3cb6c1c211484f3a601790b68

Revision fbc78367 (diff)
Added by Robert Lemke over 9 years ago

[+BUGFIX] ExtJS (ExtDirect): Fixed a bug which resulted in a broken communication between client and server via ExtDirect if a shared action method had zero required arguments. Resolves #9323, relates to #9279

Change-Id: Ic2fffd5b2b72006c212ac73ae46819056624c540

History

#1 Updated by Robert Lemke over 9 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Applied in changeset r4956.

Also available in: Atom PDF