Bug #9557

It's possible to persist multiple entities with the same identity properties

Added by Bastian Waidelich over 11 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Should have
Category:
Persistence
Target version:
-
Start date:
2010-09-01
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

I annotated the "email" property of my test model with an @identity annotation. Now I would expect the persistence layer to prevent me from storing multiple instances with the same email in a repository.
But that's not the case. Is that a (missing) feature or a bug?


Related issues

Related to TYPO3.Flow - Feature #29547: @identity should make property unique in DatabaseResolvedChristian Müller2012-04-30

Actions
#1

Updated by Karsten Dambekalns about 11 years ago

Missing feature, it should do that.

#2

Updated by Karsten Dambekalns about 11 years ago

  • Status changed from New to Accepted
  • Assignee set to Karsten Dambekalns
  • Target version set to 1.0 alpha 13
#3

Updated by Karsten Dambekalns about 11 years ago

  • Target version changed from 1.0 alpha 13 to 1.0 alpha 14
#4

Updated by Karsten Dambekalns over 10 years ago

  • Target version changed from 1.0 alpha 14 to 1230
#5

Updated by Karsten Dambekalns about 10 years ago

  • Target version deleted (1230)
#7

Updated by Christian Müller over 9 years ago

  • Assignee changed from Karsten Dambekalns to Christian Müller
  • Has patch set to No
#8

Updated by Christian Müller over 9 years ago

  • Status changed from Accepted to Rejected

I will drop this ticket in favor of #29547 which is more concise in its title. The issue is the same.

Also available in: Atom PDF