From 2008-10-10 to 2008-11-08


18:09 Bug #1986: changes in TemplateView
No problem :-) Good suggestion, I changed it. Sebastian Kurfuerst
12:30 Bug #1986: changes in TemplateView
Sebastian Kurfuerst wrote:
> done
Sorry, this comes a bit late: I think it should be "templatePathPattern" instea...
Bastian Waidelich
10:25 Bug #1986 (Resolved): changes in TemplateView
done Sebastian Kurfuerst
18:08 Bug #1992 (Resolved): test scope prototype
I just checked this again, but we do not have to do anything, because the view helpers are initialized with component... Sebastian Kurfuerst
10:34 Bug #1992 (Resolved): test scope prototype
in viewhelpernode Sebastian Kurfuerst
12:05 Feature #1988 (Accepted): create multiple facets(=Interfaces) for ViewHelpers
created useChildNodes facet Sebastian Kurfuerst
10:17 Feature #1985 (Resolved): Rename core classes to "Core"
Done. Sebastian Kurfuerst


22:48 Feature #1988 (Resolved): create multiple facets(=Interfaces) for ViewHelpers
- "onParse" facet
- "useChildNodes" facet
Sebastian Kurfuerst
22:47 Feature #1987 (Resolved): TemplateView
TemplateView should add "view" (itself) to context Sebastian Kurfuerst
22:45 Bug #1986 (Resolved): changes in TemplateView
rename templatePath to templatePattern inside templateview Sebastian Kurfuerst
22:41 Feature #1985 (Resolved): Rename core classes to "Core"
Rename standard classes to core package Sebastian Kurfuerst


17:29 Bug #1930 (Resolved): Use class-based view helpers
done :) Sebastian Kurfuerst


13:57 Bug #1927 (Resolved): Rename context to VariableContainer
Sebastian Kurfuerst
13:39 Bug #1927 (Accepted): Rename context to VariableContainer
Sebastian Kurfuerst
13:32 Bug #1927 (Resolved): Rename context to VariableContainer
We just decided, that we should rename the "Context" to "VariableContainer", as this is more appropriate on what it d... Sebastian Kurfuerst
13:35 Bug #1930 (Resolved): Use class-based view helpers
after some really long long discussions with bastian, we decided that view helpers should be class-based. Finally ;-) Sebastian Kurfuerst
13:35 Bug #1929 (Resolved): HTMLSPECIALCHAR OUTPUT
HTMLSpecialChar has to be switched on somewhere (where?), and then each view helper will automatically htmlspecialcha... Sebastian Kurfuerst
13:33 Bug #1928 (Rejected): Fail silently in production mode
All runtime exceptions should be caught in production mode and outputted somewhere else. Sebastian Kurfuerst


16:34 Feature #1907 (New): Default values for view helpers based on context
We should supply a mechanism in the "ViewHelperNode" which will merge the given parameters with certain default param... Sebastian Kurfuerst


10:39 Task #1794 (Resolved): Rename "DynamicNode"
Sebastian Kurfuerst
10:04 Task #1794: Rename "DynamicNode"
Sounds good to me, go ahead ;) Bastian Waidelich


12:43 Task #1796 (Resolved): ubiquitous naming
Fixed. Sebastian Kurfuerst
09:30 Task #1794: Rename "DynamicNode"
Hey Bastian,
what do you think of "ViewHelperNode" instead of "DynamicNode" - because that is what it really does ...
Sebastian Kurfuerst


15:58 Task #1796 (Resolved): ubiquitous naming
To avoid introducing a lot of new designators and methods we should unify the naming.
That is (for example):
* rend...
Bastian Waidelich
15:53 Task #1795 (Resolved): Restructure Node Architecture
Currently we have:
* AbstractNode [implements NodeInterface]
* * ObjectAccessorNode
* * TextNode
* * DynamicNode
Bastian Waidelich
15:39 Task #1794 (Resolved): Rename "DynamicNode"
Right now we have four kinds of "nodes":
* ObjectAccessorNode
* TextNode
* RootNode
* DynamicNode
(There will ...
Bastian Waidelich

Also available in: Atom