DIP taskforce

RFC #16656 : bug : ImageMagick does not work with quotes in exec() path on Windows
http://bugs.typo3.org/view.php?id=16656
Pending in core list
Needs vote from core dev
safe_mode

RFC #13750: Bug: Several GIFBUILDER features broken for IM4, IM6 and GM
http://bugs.typo3.org/view.php?id=13750
[rewritten in 3 parts, will close when others are committed]

Issues who need some TLC:

0016755: Thumbnail generation fail
http://bugs.typo3.org/view.php?id=16755
[quotes (escapeshellarg()) are needed for paths with spaces, but this gives problems in:]
safe_mode
0005078: Umlauts not working in GIFBUILDER with php5
http://bugs.typo3.org/view.php?id=5078
(probably bug in GD with --enable-gd-jis-conf)
[needs testing with this option disabled]
0006604: GIFBUILDER: niceText and transparentColor solution
http://bugs.typo3.org/view.php?id=6604
(not really looked into)
0010568: Image Resizing / Thumbnails with GD2 instead of ImageMagick
http://bugs.typo3.org/view.php?id=10568
(seems like a new feature and can easily result in memory problems)
0008763: Cropping gif images
http://bugs.typo3.org/view.php?id=8763
(Needs a lot of testing with various versions of IM)
0015347: Array returned by t3lib_stdGraphic::imageMagickIdentify() contains useless value for file extension 
http://bugs.typo3.org/view.php?id=15347
[Array contains file extensions and this is needed as such. Found no reliable way to add file type information to array]
feedback
0008878: Cropscale incorrectly crops GIF files 
http://bugs.typo3.org/view.php?id=8878
(RFC not voted in because of incompatibility with some IM versions; duplicate of 8763)
0014795: ImageMagic auto-detection fails when using macports
http://bugs.typo3.org/view.php?id=14795
pending_in_core_list
0009344: Render text with TrueType font: Add some special chars to the test text 
http://bugs.typo3.org/view.php?id=9344
(simple, but I see no reason why and no reason why not)
0007967: imagegeneration does not work with im_path set to a path with whitespaces
http://bugs.typo3.org/view.php?id=7967
(IIRC this is fixed, and #16656 fixes related bug)
0014329: t3lib_div::imageMagickCommand incorrectly change parameters order
http://bugs.typo3.org/view.php?id=14329
(part of #13750)
0014248: replace images in install tool
http://bugs.typo3.org/view.php?id=14248
(Old logo could be replaced, religious images have been discussed and should stay)
0014204: imageMagickCommand parameters incorrectly swapped
http://bugs.typo3.org/view.php?id=14204
(duplicate of 14329)
0012098: Image processing does not work with Imagemagick 4.2.9 
http://bugs.typo3.org/view.php?id=12098
(can be closed, it's configurable)
0011993: Thumb generation fails for file with "&" in filename
http://bugs.typo3.org/view.php?id=11993
(part of 13750)
0013800: Cropping small images fails if noScaleUp is enabled
http://bugs.typo3.org/view.php?id=13800
(not directly IM related)
0013101: Enables rotation of gifbuilder images with transparent background avoiding ugly triangles / step patterns
http://bugs.typo3.org/view.php?id=13101
(alpha transparency, needs to be addressed when global solution is found)
0011522: TYPO3 doesn't support image processing for files with parentheses in names
http://bugs.typo3.org/view.php?id=11522
(needs testing)
0010874: png_truecolor = 1 prevents using 'opacity', 'intensity', 'inputlevels', 'outputlevels', 'autolevels' features in GIFBUILDER 
http://bugs.typo3.org/view.php?id=10874
0010471: Add support for geometry argument when combining images with t3lib_stdGraphic
http://bugs.typo3.org/view.php?id=10471
(pending in core list)
0006926: thumbs.php fails on cmyk images
http://bugs.typo3.org/view.php?id=6926
0005903: Cropscaling of GIF Images fails if GDlib use the function truecolor 
http://bugs.typo3.org/view.php?id=5903
0004185: GIFBUILDER ignores jpeg-quality
http://bugs.typo3.org/view.php?id=4185

Closed

0011719: Hardcoded parameter results in lengthy image rendering
http://bugs.typo3.org/view.php?id=11719
(still valid, have to do testing)
[closed; hardcoded value is only default and can be configured]
0006106: image effects: grayscale in text w/image not working 
http://bugs.typo3.org/view.php?id=6106
[closed; bug in a specific IM version; not related to TYPO3]
0000788: Menu graphics blank
http://bugs.typo3.org/view.php?id=788
[closed; versions of all used software are way past EOL, no related bugs found]
0015981: Generating thumbnails with umlauts in backend
http://bugs.typo3.org/view.php?id=15981
[closed as duplicate of #12661 after confirmation of the reporter]
0014147: Request for GIFBUILDER breakWidth to accept data 
http://bugs.typo3.org/view.php?id=14147
[closed as duplicate; included in the stdWrap4all project]
0006707: Read from and write to same file hangs GM on network file system
http://bugs.typo3.org/view.php?id=16707
[committed to trunk]
0015133: Rendering Images with ImageMagick fails in case of file-permissions
http://bugs.typo3.org/view.php?id=15133
[committed]
0014891: Images don't get compressed 
http://bugs.typo3.org/view.php?id=14891
[Could not reproduce this]
[closed because reporter couldn't reproduce it in 4.4.6, 4.3 and it couldn't be reproduced in trunk]