Bug #1257

The dirty monitoring aspect works only for classes actually having a constructor.

Added by Karsten Dambekalns over 13 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Must have
Category:
Persistence
Target version:
-
Start date:
2008-08-11
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

When cerating an entity class, the registerNewObject() advice only works if the target class actually has a constructor. This is caused by the use of @afterreturning in conjunction with __construct.

Two possible ways out of this:
  • use introduction if no constructor is present
  • instead of using an advice hook into the component factory - if one uses new to create an object it won't be an AOP proxy anyway and persistence fails in any case
#1

Updated by Karsten Dambekalns over 13 years ago

  • Status changed from New to Accepted
  • Assignee set to Karsten Dambekalns
  • Start date set to 2008-08-11
#2

Updated by Karsten Dambekalns over 13 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Applied in changeset r1139.

Also available in: Atom PDF