Bug #25881

Inherited methods cannot be adviced

Added by Robert Lemke over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Must have
Assignee:
Category:
AOP
Start date:
2011-04-11
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Due to a bug in the AOP Proxy Class Builder methods of the target class which have been inherited from a parent class but haven't been overridden by the target class are not adviced. The problem is cause by using get_class_methods() instead of the corresponding ReflectionClass method. get_class_methods() only returns the names of methods which are declared directly in the given class while $class->getMethods() also returns those methods which were declared in a parent class.

Also available in: Atom PDF