Feature #26692

String comparison support for f:if

Added by Martin Br├╝ggemann over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Must have
Category:
ViewHelpers
Target version:
-
Start date:
2011-05-07
Due date:
% Done:

0%

Estimated time:
Has patch:
No

Description

I think it's really necessary that <f:if> fully supports simple string comparisons like this:

<f:if condition="{object.type} == 'cat'">
  <p>I am a cat.</p>
</f:if>

Today every string comparison has to be workarounded by setting additional boolean view-variables at the controller.

<f:if condition="{isCat}">
  <p>I am a cat.</p>
</f:if>

Related issues

Is duplicate of TYPO3.Fluid - Feature #26665: Fluid: Implement String comparisonResolved2010-03-10

Actions
#1

Updated by Bastian Waidelich over 10 years ago

  • Status changed from New to Rejected
  • Assignee set to Bastian Waidelich

Thanks for reporting, but this is a duplicate of #26665 ;)

Also available in: Atom PDF