Bug #27781

Feature #36172: Forge cleanup and update umbrella issue

Cannot change background color or image of a project

Added by Reinhard Führicht over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2011-06-30
Due date:
% Done:

100%


Description

I want to change the background image and color of the header section in one of my projects.
Whatever I enter in one of these fields is not saved:

  • Header Image
  • Topbar Background Color (CSS Colors)
  • Topbar Text Color (CSS Colors)
  • Quicklinks

The other fields like Name, Description and Homepage can be changed.


Related issues

Duplicated by forge.typo3.org - Bug #41642: Can't update quicklinks and logo of projects Closed 2012-10-06
Duplicated by forge.typo3.org - Bug #44100: unable to change header image and CSS colours on forge.typo3.org Closed 2012-12-19
Duplicated by forge.typo3.org - Bug #48790: Cannot update quicklinks of "contexts" extension Closed 2013-06-03

History

#1 Updated by Alexander Grein about 8 years ago

I can confirm this problem. Please fix it, my current background picture is so ugly!

#2 Updated by Steffen Gebert almost 8 years ago

  • Status changed from New to Accepted

#3 Updated by Francois Suter almost 8 years ago

Very annoying indeed. It used to work in the past, as I have some projects where I could make the changes.

#4 Updated by Andreas Becker over 7 years ago

Problem still exists. Is there any way i can help to fix that problem?

#5 Updated by Steffen Gebert almost 7 years ago

Note to myself: To manually upload a file, place it under ~/redmine/public/images/headerimages/<project_id>.jpg

#6 Updated by Michael Schams over 6 years ago

BUMP .... any chance to get this issue fixed, which has been reported over 1.5 years ago? :-)

#7 Updated by Peter Niederlag over 6 years ago

  • Assignee set to Peter Niederlag
  • % Done changed from 0 to 30

At first it's a problem with permissions on field access. This is fixed now via this patch:

https://github.com/TYPO3/rm_flow_design_helpers/commit/af565ed51b084cff6239819cf494132794b827c5

I'll now further dig into the file issue...

#8 Updated by Peter Niederlag over 6 years ago

  • Parent task set to #36172

#9 Updated by Peter Niederlag over 6 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 30 to 90

Fix is done in dev instance and will be part of the update which is going to become true really soon.

#10 Updated by Reinhard Führicht over 6 years ago

Thanks for fixing this.
Is it fixed in the live instance too now?
I just tried to change the background, but it didn't work.

#11 Updated by Bastian Bringenberg over 6 years ago

We have problems with the SVN integration ( user rights and so on ) so the update did not yet happen.

#12 Updated by Michiel Roos almost 6 years ago

BUMP

#13 Updated by Bastian Bringenberg almost 6 years ago

Hey Michiel, Bumping is nice, but it is not speeding anything up. We have right now a lot of work combined with the update. If you follow @TYPO3Server on twitter you will have mentioned, that we've had a meeting the last few days in hamburg and got a lot of things done. Right now there are still things, that work not pretty well and we need more time before updateing this huge project..

#14 Updated by Michael Stucki about 4 years ago

  • Status changed from Resolved to Accepted
  • % Done changed from 90 to 50

Text and background color are fixed, but you can also set a background image, which does not work yet.

#15 Updated by Peter Niederlag about 4 years ago

It seems that the background image can even be changed but won't be reflected in the output until caches are invalidated. As of today an updated image showed up on a project where e did some testing last friday night.

#16 Updated by Peter Niederlag about 4 years ago

  • Status changed from Accepted to In Progress
  • Assignee changed from Peter Niederlag to Michael Stucki
  • % Done changed from 50 to 100

- Backgrund image can be changed
- It needs a reload to see the changed background image

This is true with admin permissions at least, someone with an unprivileged account around for testing on another project?

#17 Updated by Michael Stucki about 4 years ago

  • Status changed from In Progress to Resolved

Great, many thanks!

#18 Updated by Steffen Gebert over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF