Bug #29419

It is impossible to use the Collection interface in "type hints"

Added by Karsten Dambekalns over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Should have
Category:
Utility
Start date:
2011-09-01
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Currently it is not possible to use the Collection interface for @param or @var annotations, because the TypeHandling doesn't consider it a valid collection type. For the sake of decoupling it should be possible to do so, though.


Related issues

Is duplicate of TYPO3.Flow - Bug #27825: TypeHandling should use the Collection interface as collection type ClosedKarsten Dambekalns2011-07-04

Actions

Also available in: Atom PDF