Bug #3544

CLI logs end up in the Web folder due to bug in Utility\Environment

Added by Karsten Dambekalns over 12 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Must have
Category:
Environment
Start date:
2009-06-03
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

CLI logs end up in the same folder as Web logs, due to a bug introduced with r2525 (which fixed #3535).

#1

Updated by Tim Eilers over 12 years ago

Found the Bug, but you have to invent the solution ;)

The Problem is, that the constructor of the Enviroment class calls $this->getSAPIType. In $this->getSAPIType the content of the membervar $this->SAPIName is used. But that content is set with initializeObject. Since you use "new" and not the Object Framework in the FLOW3 basic class the initializeObject method is not called at this point. So $this->SAPIName is empty and the switch in $this->getSAPIType defaults to Web.

#2

Updated by Karsten Dambekalns over 12 years ago

Tim Eilers wrote:

Found the Bug, but you have to invent the solution ;)

Heh, I found the bug when having a beer with Robert after the release :) We figured it would still work for most people, as the logfiles are created 777, and decided to fix this for the next alpha.

Solution has been invented and committed...

#3

Updated by Karsten Dambekalns over 12 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Fixed as of r2564.

Also available in: Atom PDF