Bug #36859

URLs Break if the Route return a URI with Query string

Added by Marc Neuhaus over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
MVC - Routing
Target version:
-
Start date:
2012-05-05
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Yes
Complexity:

Description

In cases where the Route returns an URI with a Query String attached the URI Builder adds a second ? to append the query string. In my case this happens through the BackendModuleArgumentsRoutePartHandler which already adds a query string.

I've attached a patch to check the matchingUri for a ? to append the query with a ? or & depending on that check.


Files

Route.php.diff (429 Bytes) Route.php.diff Marc Neuhaus, 2012-05-05 11:48

Related issues

Is duplicate of TYPO3.Flow - Bug #33519: Route always appends a question mark even if the route already has argumentsResolvedAske Ertmann2012-01-29

Actions

Also available in: Atom PDF