Bug #41418

Manifestpath detection broken, exception in production context

Added by Karsten Dambekalns about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Must have
Category:
Package
Start date:
2012-09-27
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

In production context class loading fails because the classloader has a wrong map for namespaces. This is caused by getNamespace() doing the wrong thing - because it finds no composer manifest. See screenshot for why.


Files

manifestpath-error.png (419 KB) manifestpath-error.png Karsten Dambekalns, 2012-09-27 13:37

Related issues

Related to TYPO3 Flow Base Distribution - Story #41031: Composer support for packagingResolvedChristian Jul Jensen2012-09-17

Actions

Also available in: Atom PDF