Task #41808

Flow does not support Windows versions older than Windows Vista or Windows Server 2008 (Error #1312463704)

Added by Jean-Sébastien Gervais over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-10-09
Due date:
% Done:

0%

Estimated time:

Description

While trying to load up the setup page for a first install. The message may be a bit misleading as I am working on a windows XP machine (virtualized) with under xampp

#1

Updated by Jean-Sébastien Gervais over 9 years ago

You can close/delete this bug report, it is only the error message that was a bit confusing.

PHP_WINDOWS_VERSION_MAJOR is 5 for windows XP.

I see no issue with the code. However, after some digging, I found a similar check in Packages\Application\TYPO3.Setup\Classes\TYPO3\Setup\Core\BasicRequirements.php than the Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Bootstrap.php

BasicRequirements.php

if (DIRECTORY_SEPARATOR !== '/' && PHP_WINDOWS_VERSION_MAJOR < 6) {
return new Error('Flow does not support Windows versions older than Windows Vista or Windows Server 2008, because they lack proper support for symbolic links.', 1312463704);
}

Bootstrap.php
if (DIRECTORY_SEPARATOR !== '/' && PHP_WINDOWS_VERSION_MAJOR < 6) {
echo('Flow does not support Windows versions older than Windows Vista or Windows Server 2008 (Error #1312463704)' . PHP_EOL);
exit(1);
}

#2

Updated by Christian Müller over 9 years ago

  • Status changed from New to Rejected

Error message is fine IMHO. Windows Vista (PHP_WINDOWS_VERSION_MAJOR === 6) works while Windows XP doesn't.

Also available in: Atom PDF