Bug #41893

Could not retrieve sha1 of git branch master

Added by Martin Lauer about 9 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
Target version:
-
Start date:
2012-10-11
Due date:
% Done:

0%

Estimated time:

Description

Got exception "Could not retrieve sha1 of git branch "master"" but rollback disabled. Stopping.

The task typo3.surf:gitcheckout fails, but

git ls-remote ssh://git@hostname/project refs/heads/master | awk '{print $1 }' 

delivers a sha1.

Access to the Repo is done via ssh pubkey auth.

#1

Updated by Cedric Ziel almost 9 years ago

It's an indirect issue not only for Surf...

You have to add the keys properly on all hosts.

So for example:

The host deployed to has to know the host-key of the git (ssh) server.

#2

Updated by Tobias Liebig about 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Martin Lauer

Like Cedric, i think this is an issue in your setup, not in Surf itself.

Surf expects the remote node has access to the git repository. Actually Surf connects to the remote host by SSH and executes the git fetch/ls-remote/checkout stuff on the remote host.

If your remote host has no access to the git repository, you might want to checkout the new "flexible transfer method" changes we recently merged.
https://review.typo3.org/#/q/status:merged+project:Packages/TYPO3.Surf+branch:master+topic:flexible-transfer-update,n,z
This enables Surf to do a git checkout locally (where Surf is running) and transfer the code to the remote hosts be using rsync.

#3

Updated by Helmut Hummel almost 6 years ago

  • Status changed from Needs Feedback to Rejected

obviously not a bug

Development of TYPO3 Surf now moved to Github. If you think this is still relevant, please open a bug report or feature request here:

https://github.com/TYPO3/Surf

Also available in: Atom PDF