Feature #43143

Fix case of class names to generate

Added by Bastian Waidelich almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Target version:
-
Start date:
2012-11-20
Due date:
% Done:

0%

Estimated time:

Description

When specifying a model name starting with a lower case character, the generated code throws an exception.
Example from the mailing list:

./flow3 kickstart:actioncontroller --generate-actions --generate-related Fritdrop.Webpage golfEquipment

leads to:
12-11-18 19:56:33 11136      DEBUG     FLOW3                Reflected class names did not match class names to reflect
12-11-18 19:56:33 11136      DEBUG     FLOW3                Reflecting class Fritdrop\Webpage\Controller\GolfEquipmentController
12-11-18 19:56:33 11136      DEBUG     FLOW3                Reflecting class Fritdrop\Webpage\Domain\Model\GolfEquipment
12-11-18 19:56:33 11136      DEBUG     FLOW3                Reflecting class Fritdrop\Webpage\Domain\Repository\GolfEquipmentRepository
12-11-18 19:56:33 11136      INFO      FLOW3                Reflected 3 emerged classes.
12-11-18 19:56:36 11136      DEBUG     FLOW3                Built AOP proxy for class "Fritdrop\Webpage\Domain\Model\GolfEquipment".
12-11-18 19:56:36 11136      DEBUG     FLOW3                Building DI proxy for "Fritdrop\Webpage\Controller\GolfEquipmentController".
12-11-18 19:56:36 11136      CRITICAL  FLOW3                Uncaught exception #1265213849 in line 142 of Packages/Framework/TYPO3.FLOW3/Classes/Object/DependencyInjection/ProxyClassBuilder.php: The object "Fritdrop\Webpage\Domain\Repository\golfEquipmentRepository" which was specified as a property in the object configuration of object "Fritdrop\Webpage\Controller\GolfEquipmentController" (automatically registered class) does not exist. Check for spelling mistakes and if that dependency is correctly configured. - See also: 20121118195633ff72d8.txt 

Instead the exception should be thrown while executing the command or the kickstarter should automatically convert class names to UpperCamelCase


Related issues

Is duplicate of TYPO3.Kickstart - Feature #43144: Fix case of class names to generateResolvedBastian Waidelich2012-11-20

Actions
#1

Updated by Bastian Waidelich almost 9 years ago

  • Status changed from New to Closed
  • Assignee set to Bastian Waidelich

Oops, duplicate of #43144

Also available in: Atom PDF