Bug #45184

Additional identity filed are not rendered, after validation error

Added by Dominique Feyer over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
ViewHelpers
Target version:
-
Start date:
2013-02-05
Due date:
% Done:

0%

Has patch:
No

Description

Found a strange bug this afternoon. I have a form with children object, when the form is rendered I have 3 hidden fields with the different __identity value, but after a validation error I only see on hidden field with the identity of the main object.

I my case, this cause a big trouble, has Flow build a new object, and doctrine is configured to cascade persist on a one to one relation. This cause the child object data to be "replaced" by the new object data, and I loose all the property of the object that are not in the form.

Patch if coming


Related issues

Duplicated by TYPO3.Fluid - Bug #46038: Subproperty with Radio fields doesn't render hidden identity property Closed 2013-03-05

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18031

#2 Updated by Bastian Waidelich over 6 years ago

  • Status changed from Under Review to Closed
  • Assignee set to Bastian Waidelich

Closing as duplicate of #29290 and #46038 – I'll take care of this now

Also available in: Atom PDF