Bug #46053

Booting->initializeSystemLogger() uses a fixed $loggerObjectName, rather than fetch it from Settings.yaml

Added by Thiago Colares over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Must have
Category:
Log
Target version:
-
Start date:
2013-03-05
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.3
Has patch:
No
Complexity:
easy

Description

It should be set by Settings.yaml instead. So...

File: \TYPO3\Flow\Core\Booting

/**
 * Initializes the System Logger
 *
 * @param \TYPO3\Flow\Core\Bootstrap $bootstrap
 * @return void
 */
static public function initializeSystemLogger(Bootstrap $bootstrap) {
    ...
    $systemLogger = \TYPO3\Flow\Log\LoggerFactory::create('SystemLogger', 'TYPO3\Flow\Log\Logger', $settings['log']['systemLogger']['backend'], $settings['log']['systemLogger']['backendOptions']);
    ...
}

Should something like

/**
 * Initializes the System Logger
 *
 * @param \TYPO3\Flow\Core\Bootstrap $bootstrap
 * @return void
 */
static public function initializeSystemLogger(Bootstrap $bootstrap) {
    ...
    $systemLogger = \TYPO3\Flow\Log\LoggerFactory::create('SystemLogger', $settings['log']['logger']['backend'], $settings['log']['systemLogger']['backend'], $settings['log']['systemLogger']['backendOptions']);
    ...
}

Note: I'm using $settings['log']['logger'] rather than 'TYPO3\Flow\Log\Logger'. Consequently, the Settings.yaml should be updated:

TYPO3:
  Flow:
    log:
      ...
      systemLogger:
        ...
        logger: 'TYPO3\Flow\Log\Logger'


Files

46053 (2.37 KB) 46053 a patch (untested) Thiago Colares, 2013-03-06 01:28

Related issues

Related to TYPO3.Flow - Task #47346: Configuration schema for doctrine cacheImplementation still existsResolved2013-04-18

Actions
Is duplicate of TYPO3.Flow - Bug #40738: Move System logger className to Settings instead of Objects.yamlResolvedKarsten Dambekalns2012-09-07

Actions
#1

Updated by Thiago Colares over 8 years ago

#2

Updated by Karsten Dambekalns over 8 years ago

  • Category set to Log
#3

Updated by Karsten Dambekalns over 8 years ago

  • Status changed from New to Closed
  • Assignee set to Karsten Dambekalns

See #40738 for progress.

#4

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Closed to Under Review

Patch set 2 for branch 2.0 has been pushed to the review server.
It is available at https://review.typo3.org/19084

#5

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch 2.0 has been pushed to the review server.
It is available at https://review.typo3.org/19084

#6

Updated by Henrik Møller Rasmussen over 8 years ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF