Bug #46465

ObjectAccess::getProperty() breaks on \stdClass due to accessor cache

Added by Karsten Dambekalns over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Must have
Category:
Reflection
Start date:
2013-03-20
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

When using getProperty() on \stdClass instances, the accessor cache leads to false results - because the class name alone in this case does not tell anything about the availability of a property.

#1

Updated by Karsten Dambekalns over 8 years ago

  • Target version changed from 2.0 to 2.1
#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19082

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19082

#4

Updated by Karsten Dambekalns over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch composer has been pushed to the review server.
It is available at https://review.typo3.org/19376

#6

Updated by Karsten Dambekalns over 8 years ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF