Bug #4666

Reflection service broken

Added by Bastian Waidelich about 12 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Must have
Category:
Reflection
Start date:
2009-09-17
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Since r3183 FLOW3s reflection service seems to be broken.
in F3\FLOW3\Reflection\Service::reflectEmergedClasses() we iterate through registered classes and call buildClassSchemata() for all classes tagged as entity or valueobject.
The problem isClassTaggedWith($className, 'entity') will always return FALSE cause the Service is not initalized at that time.

#1

Updated by Karsten Dambekalns about 12 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version set to 1.0 alpha 5
#2

Updated by Karsten Dambekalns about 12 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Applied in changeset r3191.

Also available in: Atom PDF