Bug #47249

Uncaught Exception in ActionController

Added by Marco Falkenberg over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
MVC
Target version:
-
Start date:
2013-04-15
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

In ActionController::getActionMethodParameters a Warning (strpos(): Offset not contained in string) is thrown while stripping out the 'Action' out of method names shorter than 6 characters.

    static public function getActionMethodParameters($objectManager) {
...
            if (strpos($methodName, 'Action', strlen($methodName) - 6) !== FALSE) {
...
    }

Related issues

Is duplicate of TYPO3.Flow - Bug #47469: ActionController issues PHP warning if it contains methods with short namesResolvedRobert Lemke2013-04-23

Actions
#1

Updated by Robert Lemke over 7 years ago

  • Status changed from New to Closed

Duplicate

Also available in: Atom PDF