Bug #49289

Serialization error on WebRedirect with PHP 5.3

Added by Christopher Hlubek over 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Must have
Category:
-
Start date:
2013-06-20
Due date:
% Done:

100%

Estimated time:
PHP Version:
5.3
Has patch:
No
Complexity:

Description

With the plain serializer from PHP 5.3 there is a reproducible unserialize error when using a "WebRedirect" entry point for authentication.

It seems that recursive objects are not handled correctly in this PHP version (5.3.19) and the error is caused by serializing too much information in the session (the injected uriBuilder property of WebRedirect should never be serialized).


Related issues

Related to TYPO3.Flow - Bug #53931: ActionRequest should not serialize parent HTTP requestResolvedSebastian Kurfuerst2013-11-25

Actions

Also available in: Atom PDF