Bug #49545

Non-plural translations are not found if arguments are used

Added by Adrian Föder over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
I18n
Target version:
-
Start date:
2013-07-01
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

A simple translation which is not meant for handling plurals is not correctly resolved when used with arguements, for example,

<f:translate id="someId" arguments="{0: 2500}" />

does not resolve correctly. The error appears in \TYPO3\Flow\I18n\Translator::translateById where the $pluralForm equals to 'other' as soon as arguments are set (that's the distant observation so far, have to dig deeper).


Related issues

Is duplicate of TYPO3.Flow - Bug #45062: TranslateViewHelper fails if an array with a single number is passed as argumentsResolved2013-02-01

Actions
#1

Updated by Adrian Föder over 8 years ago

the actual reason is, that \TYPO3\Flow\I18n\Translator::getPluralForm per convention takes arguments' first item, if it's the only one and numeric, as quantity. So the above mentioned example is such a case where this problem occurs.

What could we do here?

#2

Updated by Adrian Föder over 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Assignee deleted (Adrian Föder)
#3

Updated by Alexander Berl over 8 years ago

See duplicated bug #45062, the fix is already accepted and only needs to get merged.

#4

Updated by Adrian Föder over 8 years ago

  • Status changed from Needs Feedback to Closed

closed as being duplicate of #49545
Thanks Alex for the notice!

#5

Updated by Bastian Waidelich over 8 years ago

Adrian Föder wrote:

closed as being duplicate of #49545

duplicate of -> #45062 ;)

Also available in: Atom PDF