Feature #5068

Implement validation for settings (or configuration in general)

Added by Robert Lemke almost 12 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Configuration
Target version:
-
Start date:
2009-10-21
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Currently settings, which are typically defined in .yaml files, won't be validated by FLOW3. It would, however, be quite convenient for a developer if he could rely on validated settings.

One way to implement this would be by introducing annotations for yaml comments. The developer would then define the expected datatype and additional validators in his Settings.yaml template file and these rules would be enforced while settings are appplied by the Configuration Manager.

Example:

Foo:

  /**
   * @type string
   * @validate StringLenth(minimum = "10")
   */
  title: "The title of something" 


Related issues

Is duplicate of TYPO3.Flow - Feature #31277: Schema based validation for arraysResolvedMartin Ficzel2011-10-25

Actions
#1

Updated by Martin Ficzel over 9 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF