Bug #524

Can't create FLOW3 Package without creating a project before

Added by Peter Kraume over 12 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Should have
Category:
New Package Wizard (FLOW3)
Target version:
Start date:
2008-05-13
Due date:
% Done:

100%

Estimated time:
0.00 h

Description

Not sure if this is a bug or intended, but you have to create a project first. Otherwise the folder property is empty.
The error occured after a fresh PDT installation.

History

#1 Updated by David Bruehlmeier over 12 years ago

  • Status changed from New to Rejected
  • % Done changed from 0 to 100

Hi Peter,

it's a feature, not a bug :-) The wizard expects an existing project, typically a PHP project. New packages can only be created in an existing project.

The reason behind it is the fact that DEV3 does not create projects on its own, since it is built on top of existing PHP IDE's, such as Zend's PDT.

Greetings, Dave

#2 Updated by Sebastian Böttger over 12 years ago

  • Status changed from Rejected to New

I'd say this is discussuble:
You're right if you say we offer a pckage wizard and not a project wirzard. But I guess it was Martin Holtz who had the same "problem" on the Developer Days.
I'd say, regarding the Usability, we should at least offer a possibility that the wizard offers a link to create a new PHP project if none's existing.

Regards
Sebastian

#3 Updated by David Bruehlmeier over 12 years ago

  • Status changed from New to Accepted
  • % Done changed from 100 to 0

OK, I will add a link to jump to the "Create New Project" Wizard.

#4 Updated by David Bruehlmeier over 12 years ago

  • Target version changed from 0.1 to 0.2

#5 Updated by David Bruehlmeier over 12 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF