Bug #52468

allow local

Added by Felix Oertel about 8 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Target version:
-
Start date:
2013-10-02
Due date:
% Done:

100%

Estimated time:

Description

the doc say

* @param \TYPO3\Surf\Domain\Model\Node $node Node to execute command against, NULL means localhost

but the definition actually is

public function execute($command, Node $node, ...

so it's not possible to execute local commands. This makes composer fail for me, because it tries to look up the composer.json (test -f) on the remote server instead of the local workspacePath.

#1

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24290

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24290

#3

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24296

#4

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24296

#5

Updated by Gerrit Code Review about 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24296

#6

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 4 for branch master of project Packages/TYPO3.Surf has been pushed to the review server.
It is available at https://review.typo3.org/24296

#7

Updated by Lars Malach about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF