Task #55189

Extract forward handling from errorAction

Added by Oliver Hader almost 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-01-20
Due date:
% Done:

0%


Description

basically taken from Extbase tracker, see #55178 and please let me know whether this might be considered for TYPO3 Flow

The default ActionController::errorAction uses the forward method to get back to the referring request.
If a custom and different redirect shall happen here, one has to clone the whole errorAction method.
Extracting the handling simplifies customization at this state.


Related issues

Related to TYPO3 Core - Task #55178: Extract forward handling from errorAction Closed 2014-01-20
Duplicates TYPO3.Flow - Task #54618: Split up ActionController::errorAction() Resolved 2013-12-28

History

#1 Updated by Bastian Waidelich almost 5 years ago

  • Status changed from New to Closed
  • Assignee set to Bastian Waidelich
  • translation missing: en.field_remaining_hours set to 0.0

If I'm not mistaken this is a duplicate of #54618 which has been resolved in TYPO3 Flow 2.3 (please comment or re-open if I'm wrong)

Also available in: Atom PDF