Bug #56974

Own nodetype: Uncaught TypeError: Cannot call method 'render' of undefined - vie.js:6768

Added by Soren Malling over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-03-17
Due date:
% Done:

0%


Description

Configured NodeType
TS


prototype(Meteko.Homepage:PostList) < prototype(TYPO3.Neos:Menu) {
    #items = ${q(site).find('[instanceof Meteko.Homepage:Post]')}
    templatePath = 'resource://Meteko.Homepage/Private/Templates/NodeTypes/PostList.html'
    itemCollection = ${q(site).children('blog').children().get()}
}

YAML

'Meteko.Homepage:PostList':
  superTypes: ['TYPO3.Neos.NodeTypes:Menu']
  ui:
    label: 'Blog Post List'

When I place a instance of Meteko.Homepage:PostList on a page the following javascript error is thrown

Uncaught TypeError: Cannot call method 'render' of undefined                   vie.js:6768

After this, no other content elements can be inserted

Afterward reloading the page, my structure got the element, but it's not being rendered

https://www.evernote.com/shard/s58/sh/fc6d40fc-381a-4895-9383-c9cd3f6a4879/06b0c562701f03fdce65b61b8ebd2125

History

#1 Updated by Philipp Hanebrink almost 5 years ago

  • Description updated (diff)
  • Status changed from New to Closed
  • Assignee set to Philipp Hanebrink

Could not reproduce in version 1.1.
If this is still an issue for you please open an issue on http://jira.typo3.org/

Also available in: Atom PDF