Bug #56975

Publish own nodetypes throws a exception @ cache clearing

Added by Soren Malling over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-03-17
Due date:
% Done:

0%


Description

Another issue apperead while working with #56974

I've defined my own nodetypes with the following configuration


prototype(TYPO3.Neos:PrimaryContent).blogPost {
    condition = ${q(documentNode).is('[instanceof Meteko.Homepage:Post]')}
    type = 'Meteko.Homepage:Post'
    title  = ${this.title}
}

prototype(Meteko.Homepage:Post) < prototype(TYPO3.TypoScript:Template) {
    templatePath = 'resource://Meteko.Homepage/Private/Templates/TypoScript/Post.html'
    title = ${q(node).property('title')}
    node = ${node}

        # Render the main ContentCollection of the Post like a page would
    main = TYPO3.Neos:ContentCollection {
        nodePath = 'main'
    }
}

prototype(Meteko.Homepage:PostList) < prototype(TYPO3.Neos:Menu) {
    #items = ${q(site).find('[instanceof Meteko.Homepage:Post]')}
    templatePath = 'resource://Meteko.Homepage/Private/Templates/NodeTypes/PostList.html'
    itemCollection = ${q(site).children('blog').children().get()}
}

When i create a new page of my own nodetype, place some content element and publish the cache clearing chokes at this point

/var/log/apache2/error_log:27332:[Sun Mar 16 00:54:08 2014] [error] [client 127.0.0.1] PHP Fatal error:  Call to a member function getIdentifier() on a non-object in /Users/sorenmalling/Sites/Neos/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/TYPO3_Neos_TypoScript_Cache_ContentCacheFlusher.php on line 72, referer: http://meteko.sma/neos/management/workspaces

at this place, it doe's a check for depth and tries to clear cache the for parent node. For some reason, the "parent" node (my custom page nodetype) can't seem to be resolved.

History

#1 Updated by Philipp Hanebrink over 4 years ago

  • Assignee set to Philipp Hanebrink

#2 Updated by Philipp Hanebrink over 4 years ago

  • Status changed from New to Closed

Could not reproduce in version 1.1
If this is still an issue for you please open an issue on http://jira.typo3.org/

Also available in: Atom PDF