Bug #6298

action gets converted to lowercase

Added by Falk Kühnel almost 11 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-02-01
Due date:
% Done:

0%

Estimated time:
Has patch:

Description

If i recall correctly, this was done to somehow get teh dispatcher to ignore cases for actions.

I am trying to use Fluid with an explicitly called action like this in 4.3:
$view->render('someName');
This makes Fluid look for a file called 'somename', which in my oppinion should not be.

TemplateView.php:

protected function resolveTemplatePathAndFilename($actionName = NULL) {
...
   $actionName = ($actionName !== NULL ? $actionName : $this->controllerContext->getRequest()->getControllerActionName());
   $actionName = strtolower($actionName);
...
}

This is not the right place to do this. this should be done somewhere, in getControllerActionName.
Partials dont get converted to lowercase names btw.


Related issues

Is duplicate of TYPO3.Fluid - Task #7243: let's use UpperCamelCase filenames for templates as wellResolvedBastian Waidelich2010-04-132010-06-18

Actions
#1

Updated by Sebastian Kurfuerst over 10 years ago

  • Status changed from New to Resolved

is duplicate of #7243.

Also available in: Atom PDF