Bug #8317

Parse Error in FLOW3 script with PHP < 5.3

Added by Bastian Waidelich over 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Should have
Category:
Core
Start date:
2010-09-26
Due date:
% Done:

100%

Estimated time:
1.00 h
PHP Version:
Has patch:
Complexity:

Description

When calling php Packages\Framework\FLOW3\Scripts\FLOW3.php with PHP 5.2.x I'm getting a parse error.

$className = '\F3\FLOW3\Core\Bootstrap';
$className::defineConstants();

should have been the workaround to prevent the parser from dying with a parse error. But the second line throws
Parse error: parse error in Packages\Framework\FLOW3\Scripts\FLOW3.php on line 38

on my windows machine with PHP 5.2.10-dev

#1

Updated by Karsten Dambekalns about 11 years ago

  • Project changed from 30 to TYPO3.Flow
  • Category deleted (323)
#2

Updated by Karsten Dambekalns about 11 years ago

  • Category set to Core
  • Status changed from New to Needs Feedback
  • Assignee set to Karsten Dambekalns
  • Start date changed from 2010-06-17 to 2010-09-26
  • Estimated time set to 1.00 h

Without that line, does the version check work as intended?

#3

Updated by Christian Müller about 11 years ago

Without
$className::defineConstants();

the version check works (just tested). Idea would be to move the version check to /Web/index.php. There it works (tested too).

#4

Updated by Karsten Dambekalns about 11 years ago

  • Status changed from Needs Feedback to Under Review
  • Target version set to 1.0 alpha 12
#5

Updated by Karsten Dambekalns about 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF