Feature #15180

add config'able FE user storage page

Added by Christoph Koehler almost 14 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Should have
Category:
felogin
Target version:
-
Start date:
2005-11-06
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Ability to configure a page with the frontpage users.
This is from the newloginbox_tmplable extension by Miroslav Monkevic <>
I don't know if you need his permission first, I am sure he won't mind.

Just replace around line 87:

// Get storage PIDs:
$d=$GLOBALS['TSFE']->getStorageSiterootPids();

with:

// Get storage PIDs:
if ($this->conf['pid']) {
$d['_STORAGE_PID'] = $this->conf['pid'];
} else {
$d=$GLOBALS['TSFE']->getStorageSiterootPids();
}

Now you can configure it like so:
plugin.tx_newloginbox_pi1.pid = 141

(issue imported from #M1787)

storagePid.diff View (511 Bytes) Administrator Admin, 2006-10-04 20:26

History

#1 Updated by Christoph Koehler almost 14 years ago

Sorry, didn't know the steps to reproduce weren't shown. Here are the instructions:

Just replace around line 87:

// Get storage PIDs:
$d=$GLOBALS['TSFE']->getStorageSiterootPids();

with:

// Get storage PIDs:
if ($this->conf['pid']) {
$d['_STORAGE_PID'] = $this->conf['pid'];
} else {
$d=$GLOBALS['TSFE']->getStorageSiterootPids();
}

Now you can configure it like so:
plugin.tx_newloginbox_pi1.pid = 141

#2 Updated by Christopher Hlubek almost 13 years ago

This would be a nice feature to have. In our site we include the newloginbox plugin on every site and we are using TemplaVoila so it's uncool to set the GRSP for another user storage folder.

It's easy to fix (yet open since almost a year??), just change (Line 80 in 3.0.0)


// Get storage PIDs:
$spid = $GLOBALS['TSFE']->getStorageSiterootPids();


to


// Get storage PIDs:
$spid = isset($this->conf['pid']) ? $this->conf['pid'] : $GLOBALS['TSFE']->getStorageSiterootPids();


#3 Updated by Stefan Strasser almost 13 years ago

Here is a patch-file, I called 'useStoragePid' instead of 'pid'

#4 Updated by Christopher Hlubek almost 13 years ago

Okay, thats more intuitive. Thank your for the diff.

#5 Updated by Stefan Strasser almost 13 years ago

Name of the TSconfig-variable changed from useStoragePid to storagePid as used in several other extensions (hint by Ingo Renner, thanks!).

#6 Updated by Stefan Strasser almost 13 years ago

commited to svn, will be in 3.0.1

#7 Updated by Stefan Strasser almost 13 years ago

3.0.1 - which contains fix - is released

Also available in: Atom PDF