Feature #47296

Extension Manager Edit Files

Added by Markus Timtner over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2013-04-16
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

there doesn't seem to be an possibility anymore to edit files of extension in the extension manager.
Couldn't find any documentation on that either.

really nice if an extension throws a fatal error due to v6 incompatibility issues...
[like these ones: Fatal error: Call to undefined method TYPO3\CMS\Core\Utility\GeneralUtility::readLLXMLfile() in typo3conf/ext/locator/pi1/class.tx_locator_pi1_wizicon.php on line 65 ]

When the extension is installed via TER, there is simply no possibility other than downloading the ext file, editing it, zipping it and then upload zip and set overwrite flag, or do I get this wrong???

It looks like the install tool option [EXT][noEdit]=0 simply does not exist any more.

Why was this functionality removed?
Why is it not clearly communicated?

Kind regards, MT.

History

#1 Updated by Ingo Renner over 6 years ago

  • Status changed from New to Closed

The goal of the new extension manager was to be more simple and do what the name says: "manage extension". That means, installing, uninstalling, updating, and configuring extensions. Thus functionality that is not related to the mentioned activities has been removed.

I'm almost sure this has been communicated as part of the release announcements and several other news posts related to the topic.

As a good practice you should not modify extensions anyway, even if it was possible. Sorry for the inconvenience this may have caused.

#2 Updated by Markus Timtner over 6 years ago

Hello Ingo,

thank you for your answer. I totally agree with you that the EM overhaul is in essence a good thing.
I totally agree with you that a streamlined EM is a good thing, and I appreciate the good work done here.

The fact that the "edit files" feature was removed completely, wasn't clearly communicated. And I have searched quite a while.
Alas, spilled milk. Believe me, I never want to modify extensions, but sometimes someone has to do some debugging.

When removing features, it should be also be good practice to check if existing functionality might be in use by somebody; if so, it then should be reproduced somewhere.

Cheers, MT.

Also available in: Atom PDF