Bug #52812

Installing extension bringes 'Package "xy" is not available'

Added by Ernesto Baschny about 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2013-10-14
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If I copy an extension directory to typo3conf/ext/ and try to install it using the Extension Manager (it is listed already), I get:

#1166546734: Package "xy" is not available. Please check if the package exists and that the package key is correct (package keys are case sensitive). (More information)

The problem is that the PackageStates file is not up-to-date: it does not include this new package which was just copied there without the knowledge of the Package Management.

Since this is not so uncommon, I would propose to re-create the PackageStates.php file as soon as the Extension Manager tries to do something with packages to make sure it is in sync with the reality - just like it behaved before.


Related issues

Duplicates TYPO3 Core - Bug #52766: PackageManager doesn't update PackageStates Closed 2013-10-13

History

#1 Updated by Ernesto Baschny about 6 years ago

  • Status changed from Accepted to Rejected

Was solved already with #52766.

Also available in: Atom PDF