Bug #72393

Inline FAL record in gridelements flexform fails

Added by Laurent Foulloy almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-12-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Creating an inline FAL record inside a gridelements flexform terminates with a "500 internal server error".

TYPO3 7.6.2
Related to Bug #72249 and Bug #71436

Below is the flexform used in the gridelements

Thanks in advance for your help

    <ROOT type="array">
        <type>array</type>
        <el type="array">
            <image type="array">
                <TCEforms  type="array">
                    <label>Test</label>
                    <config type="array">
                        <type>inline</type>
                        <appearance type="array">
                            <useSortable>TRUE</useSortable>
                            <showAllLocalizationLink>FALSE</showAllLocalizationLink>
                            <showPossibleLocalizationRecords>FALSE</showPossibleLocalizationRecords>
                            <showRemovedLocalizationRecords>FALSE</showRemovedLocalizationRecords>
                            <showSynchronizationLink>FALSE</showSynchronizationLink>
                            <enabledControls type="array">
                                <info>FALSE</info>
                                <new>FALSE</new>
                                <dragdrop>TRUE</dragdrop>
                                <sort>FALSE</sort>
                                <hide>TRUE</hide>
                                <delete>TRUE</delete>
                                <localize>TRUE</localize>
                            </enabledControls>
                            <levelLinksPosition>both</levelLinksPosition>
                            <headerThumbnail type="array">
                                <field>uid_local</field>
                                <height>165c</height>
                                <width>177c</width>
                            </headerThumbnail>
                        </appearance>
                        <behaviour type="array">
                            <localizationMode>select</localizationMode>
                            <localizeChildrenAtParentLocalization>TRUE</localizeChildrenAtParentLocalization>
                        </behaviour>
                        <foreign_table>sys_file_reference</foreign_table>
                        <foreign_field>uid_foreign</foreign_field>
                        <foreign_sortby>sorting_foreign</foreign_sortby>
                        <foreign_table_field>tablenames</foreign_table_field>
                        <foreign_match_fields type="array">
                            <fieldname>image</fieldname>
                        </foreign_match_fields>
                        <foreign_label>uid_local</foreign_label>
                        <foreign_selector>uid_local</foreign_selector>
                        <maxitems>1</maxitems>
                        <foreign_selector_fieldTcaOverride type="array">
                            <config type="array">
                                <appearance type="array">
                                    <elementBrowserAllowed>gif,jpg,jpeg,tif,tiff,bmp,pcx,tga,png,pdf,ai</elementBrowserAllowed>
                                    <elementBrowserType>file</elementBrowserType>
                                </appearance>
                            </config>
                        </foreign_selector_fieldTcaOverride>
                    </config>
                </TCEforms>
            </image>
        </el>
    </ROOT>


Related issues

Related to TYPO3 Core - Bug #71436: Inline in flex with multiple DS failsClosed2015-11-09

Actions
Related to TYPO3 Core - Bug #72249: Inline FAL record in flexform failsClosed2015-12-15

Actions
Is duplicate of TYPO3 Core - Bug #72054: FAL inline in flexformDS failsRejected2015-12-04

Actions
#1

Updated by Morton Jonuschat almost 5 years ago

  • Status changed from New to Closed

Duplicates #72054 - Jo Hasenau (author of gridelements) is aware of the problem

Also available in: Atom PDF