Feature #80659

Set Charset to utf8mb4

Added by Harald Holzmann over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2017-04-03
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
no-brainer
Sprint Focus:

Description

I need to set the charset of the database to utf8mb4 and not utf8 (which is default).

How can i do that (in Localconfiguration or Repository)?

I found no possibility to do that? So i have changed TYPO3\CMS\Core\Database\DatabaseConnection "$connectionCharset" from 'utf8' to 'utf8mb4'. How can i change that outside the core?


Related issues

Related to TYPO3 Core - Feature #80398: Make default charset and collation for new tables configurableClosed2017-03-22

Actions
#1

Updated by Morton Jonuschat over 3 years ago

Closing this as a duplicate of #80398

#2

Updated by Morton Jonuschat over 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF