Bug #81468

Dump class loading information after extension installation

Added by Nicole Cordes over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2017-06-05
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given:

An installation without composer which should be upgraded. During upgrade wizards the installation of compatiblity6 is chosen.

Expected:

The extension is installed and upgrade can be performed afterwards.

Actual:

An exception is thrown "$hookObject \TYPO3\CMS\Compatibility6\Hooks\ExtTablesPostProcessing\TcaMigration must implement interface TYPO3\\CMS\\Core\\Database\\TableConfigurationPostProcessingHookInterface".

The exception is thrown because \TYPO3\CMS\Compatibility6\Hooks\ExtTablesPostProcessing\TcaMigration cannot be resolved due to missing autoload information.

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53119

#2 Updated by Nicole Cordes over 2 years ago

  • Status changed from Under Review to Closed

Signal/Slot information seems to be loaded in general but was not available for me during installation.

Also available in: Atom PDF