Bug #83247

Translating sys_file_metadata results in width 0 and height 0

Added by Frederik Holz almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2017-12-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Steps to reproduce:
  • upload image to folder
  • translate metadata of image
  • save
    in the database at sys_file_metadata is a new entry for the translation, but width and height is set to 0

This might not be a problem at first, but if you use a system with different crop variants the image tag of a text + image element recieves width="0" and height="0".

Debugged a little and got the point of getCroppedDimensionalProperty in GalleryProcessor. With default Crop variant set to 1:1 he tries to get a dimensional by multiplying 1*0 -> width = 0 and height = 0.
This only applies to Files with a translated meta data which results in width and height set to 0.

End result: Text + Image displays Image only in default language, if the image's meta data is translated in filelist.

TYPO3 version 8.7.8
PHP 7.1


Related issues

Related to TYPO3 Core - Bug #73076: Publishing of changed sys_file_metadata fails because of missing config array for with and height fieldsClosed2016-02-02

Actions
Is duplicate of TYPO3 Core - Bug #83140: Images not shown when metadata is translatedClosed2017-11-28

Actions
#1

Updated by Frans Saris almost 4 years ago

  • Is duplicate of Bug #83140: Images not shown when metadata is translated added
#2

Updated by Frans Saris almost 4 years ago

  • Related to Bug #73076: Publishing of changed sys_file_metadata fails because of missing config array for with and height fields added
#3

Updated by Frans Saris almost 4 years ago

  • Status changed from New to Rejected

Fixed with #73076 will be part of next release

Also available in: Atom PDF