Bug #87911

(YouTube|Vimeo)Renderer renders broken tag if additionalAttributes are defined

Added by Sascha Egerer 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2019-03-14
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since the commit a32a9a746f807b14571139f0cb7caa00b8d037a5 the Youtube and Vimeo Renderes are broken if the attribute additionalAttributes is given.

Test Case:

<f:media file="{video}" additionalConfig="{loop: 0}" additionalAttributes="{poster: ''}" />

Current result:

<iframe src="https://www.youtube-nocookie.com/embed/XXX?autohide=1&amp;controls=2&amp;enablejsapi=1&amp;origin=https%3A%2F%2FXXX&amp;showinfo=0" allowfullscreen 0="poster=&quot;&quot;" allow="fullscreen"></iframe>

Expected and previous result:

<iframe src="https://www.youtube-nocookie.com/embed/XXX?autohide=1&amp;controls=2&amp;enablejsapi=1&amp;origin=https%3A%2F%2FXXX&amp;showinfo=0" allowfullscreen poster="" allow="fullscreen"></iframe>

History

#1 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60246

#2 Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60246

#3 Updated by Gerrit Code Review 5 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60246

#4 Updated by Sascha Egerer 5 months ago

  • Status changed from Under Review to Closed

Issue occured only due to a backport to my TYPO3 8.7 version. Master works fine. Issue is invalid

Also available in: Atom PDF