Bug #92215

Respect system collection order by default

Added by Daniel Siepmann 3 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Should have
Category:
-
Start date:
2020-09-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When creating a system collection via API, it is created from database but ignores defined sorting.

Steps to reproduce:

Create a new system collection and add at least two records. Fetch the system collection via API:

\TYPO3\CMS\Core\Collection\StaticRecordCollection::create([], true);

The records might be in expected order.
Now adjust order of items in system collection record.
Refresh and the old order should be returned.

#1

Updated by Daniel Siepmann 3 months ago

  • Description updated (diff)
#2

Updated by Daniel Siepmann 3 months ago

  • Status changed from New to Rejected

Looks like the extension is not widely used anyway.
It was moved to an external repository for current master.
I've created an issue and PR there: https://github.com/FriendsOfTYPO3/legacy-collections/issues/2
I'll close the issue here and we will apply the patch for our project.

Also available in: Atom PDF