Bug #20598

Error after hide/show element

Added by Yannick Pavard almost 5 years ago. Updated 5 months ago.

Status:Resolved Start date:2009-06-08
Priority:Should have Due date:
Assignee:- % Done:

100%

Category:Workspaces Spent time: -
Target version:-
TYPO3 Version:4.2 Complexity:
PHP Version: Is Regression:
Votes: 2 (View)

Description

Hi,

This is my error :

1: Could not be edited in offline workspace in the branch where found (failure state: 'Online record was not in versionized branch!'). Auto-creation of version not allowed in workspace!

when I use hide/show button in list mode.

The first time is correct, but error appear after other click on this button.

Can you patch it ?

sorry for my bad english ;)

(issue imported from #M11303)

class.db_list_extra.patch (1.2 kB) Administrator Admin, 2009-11-26 21:11

0011303_hide_show.diff (1.8 kB) Administrator Admin, 2010-05-05 16:06

0011303_hide_show_4.4.4.diff (1.7 kB) Administrator Admin, 2010-10-08 15:12


Related issues

precedes Core - Bug #32780: Errors when hiding/unhiding and moving content Resolved 2011-12-22

Associated revisions

Revision af755f8f
Added by Simon Schaufelberger over 2 years ago

[BUGFIX] Error after hide/show element in list module

Showing or hiding an element with workspace selected will result in
Error: Could not be edited in offline workspace...

Change-Id: I43ceaf2443dff7c3d666811726353f3b17b81182
Resolves: #20598
Releases: 4.7, 4.6, 4,5
Reviewed-on: http://review.typo3.org/5633
Reviewed-by: Georg Ringer
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Francois Suter
Tested-by: Francois Suter

Revision 3726d84a
Added by Simon Schaufelberger over 2 years ago

[BUGFIX] Error after hide/show element in list module

Showing or hiding an element with workspace selected will result in
Error: Could not be edited in offline workspace...

Change-Id: I5cd55653283b49a55523cddaf1401865d476e24a
Resolves: #20598
Releases: 4.7, 4.6, 4,5
Reviewed-on: http://review.typo3.org/6702
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Francois Suter
Tested-by: Francois Suter

Revision 4b3bcbd5
Added by Simon Schaufelberger over 2 years ago

[BUGFIX] Error after hide/show element in list module

Showing or hiding an element with workspace selected will result in
Error: Could not be edited in offline workspace...

Change-Id: I768320084fd24917d22cbc1d01b47387da863605
Resolves: #20598
Releases: 4.7, 4.6, 4,5
Reviewed-on: http://review.typo3.org/6703
Reviewed-by: Georg Ringer
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Francois Suter
Tested-by: Francois Suter

History

Updated by Julia Pardanaud over 4 years ago

Hi,
When you use hide/unhide button on a versionized record, it's like if TYPO3 tries to change the LIVE version instead : it's the uid of the LIVE version which is sent.

I propose this patch which change this id when it's necessary (version 4.3).
Instead of changing class.db_list_extra.inc, we could try to change class.t3lib_tcemain.php. What is the best solution ?

sorry for my bad english too ;)

Updated by Robert Heel almost 4 years ago

This issue affects the info, move up/down, hide, delete and cut buttons ...
Only on the create translation flags it's correct to use the original id.

Updated by Robert Heel almost 4 years ago

Seems to be intentional that move and cut creates a new type of version element.
Added a easier patch 0011303_hide_show.diff

Updated by Benjamin Mack over 3 years ago

Please check if this issue still exists with trunk or 4.4.2, should be fixed since 4.4.1.

Updated by Robert Heel over 3 years ago

Didn't work with 4.4.2. When clicking two times on the show/hide button in workspace list view, this error message appears:
1: [newlog()] Could not be edited in offline workspace in the branch where found (failure state: 'Online record was not in versionized branch!'). Auto-creation of version not allowed in workspace!

Updated by Simon Schaufelberger about 3 years ago

still happens in 4.4.6 with templavoila and the light bulb. with the context menu it works

Updated by Francois Suter about 3 years ago

Indeed the bug still exists across all branches and trunk.

For TemplaVoilà, I reported the issue as a separate bug report.

Updated by Sonja Schubert almost 3 years ago

  • Status changed from New to Closed
  • Target version deleted (0)

Updated by Oliver Hader almost 3 years ago

Since currently only element versioning is supported, this issues was set to be closed

Updated by Robert Heel almost 3 years ago

Issue still exists in 4.5.2 - Why closed?

Updated by maximilian schmid almost 3 years ago

Issue still exists in 4.5.3 - 0011303_hide_show.diff solves this issue. Please include it in the next release (4.5.4)!

Updated by Tobias Liebig almost 3 years ago

Can confirm, the issue still exists in 4.5.2.
I'll test the patch

Updated by Oliver Tempel almost 3 years ago

Can confirm, too. Version 4.5.2 is still buggy.
No autopatch.

Used diff 4.4.4 to patch manually.

Added line @ 1138 $ver_uid=$row['_ORIG_uid'] ? $row['_ORIG_uid'] : $row['uid'];
Changed line @1274 $params='&data['.$table.']['.$ver_uid.']['.$hiddenField.']=0';
Changed line @1281 $params='&data['.$table.']['.$ver_uid.']['.$hiddenField.']=1';

What about up/down patch, or the other $row['uid'] in these function ?

Updated by Michael McManus almost 3 years ago

Oliver Hader wrote:

Since currently only element versioning is supported, this issues was set to be closed

Hi Oliver,

Thanks for your feedback here and your work on the project, in general. I'm having a hard time understanding why this bug is no longer open, based your explanation re: element versioning. How is it that the Show/Hide icon in the element context menu is tied to the proper versioned uid, but not with the icon that appears in the list?

Thanks!

-Michael

Updated by Tolleiv Nietsch almost 3 years ago

  • Status changed from Closed to Accepted

Agree - still valid

Updated by Mr. Hudson over 2 years ago

Patch set 1 of change I43ceaf2443dff7c3d666811726353f3b17b81182 has been pushed to the review server.
It is available at http://review.typo3.org/5633

Updated by Mr. Hudson over 2 years ago

Patch set 2 of change I43ceaf2443dff7c3d666811726353f3b17b81182 has been pushed to the review server.
It is available at http://review.typo3.org/5633

Updated by Simon Schaufelberger over 2 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Updated by Bart Dubelaar over 2 years ago

I am still experiencing this bug in 4.5.8. At least hiding and unhiding a page will throw this error, and moving a content element to the top position on a page will throw this error too. Is the merged patch already in 4.5.8 or is the target 4.5.9?

Updated by Bart Dubelaar over 2 years ago

Ok, this patch is merged in 4.5.8 but the issue is not resolved. Please reopen this ticket.

Updated by Bart Dubelaar over 2 years ago

I am currently working on improvement of the patch on class.db_list_extra.inc. However, I think that the current approach is only fixing the symptoms and not the cause.
The actual cause is in the process_datamap function of class.t3lib_tcemain.php. This function should detect if there is an existing version available in the current workspace, which it currently does not.

The process_cmdmap function does detect this. This discrepancy becomes very clear now that I am also trying to fix repositioning of an element. This action needs a cmdmap and a datamap (for the colpos) where the cmdmap takes the live id and the datamap takes the versioned id...

I can finish the patches that fix the symptoms, however I would like to have some advice on tackling the cause in tcemain. I can also work on a patch for tcemain, but this is at bit trickier and I don't know if my analysis of the problem is 100% correct.

Updated by Michael Stucki 5 months ago

  • Category set to Workspaces

Updated by Michael Stucki 5 months ago

  • Project changed from Workspaces & Versioning to Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF