Project

General

Profile

Actions

Bug #102014

closed

RTE FolderLinkHandler crashed on non-existing folder

Added by Jochen Roth 10 months ago. Updated 14 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Start date:
2023-09-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given you have a link in bodytext (RTE field) and the user clicks on save:

<a href="t3://folder?storage=1&amp;identifier=%2FDOES_NOT_EXIST%2F">FolderLinkHandler</a>

it will throw this error, because the folder does not exist

Call to a member function getStorage() on null
in /var/www/html/typo3/sysext/core/Classes/LinkHandling/FolderLinkHandler.php line 54
Actions #1

Updated by Jochen Roth 10 months ago

  • Description updated (diff)
Actions #2

Updated by Gerrit Code Review 10 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81178

Actions #3

Updated by Gerrit Code Review 10 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81178

Actions #4

Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81149

Actions #5

Updated by Anonymous 10 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Benni Mack 14 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF