Project

General

Profile

Actions

Bug #102974

closed

ext:seo: Path to Sitemap.xsl is located in path "/typo3/"

Added by Chris no-lastname-given 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
SEO
Target version:
-
Start date:
2024-01-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Like described in [this closed issue](https://forge.typo3.org/issues/90368) the path to the "Sitemap.xsl" in ext:seo points to "/typo3/sysext/seo/Resources/Public/CSS/Sitemap.xsl".

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="/typo3/sysext/seo/Resources/Public/CSS/Sitemap.xsl"?>

Since my "typo3"-directory is not available for the public, this leads to an error.

Tested with TYPO3 v11.5.34


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #90368: seo-extension: xml-sitemap refers for xsl-file to /typo3/ folder in frontend contextClosed2020-02-13

Actions
Related to TYPO3 Core - Feature #88147: Configurable path to Resources/Public/CSS/Sitemap.xsl in SEO moduleClosed2019-04-15

Actions
Actions #1

Updated by Georg Ringer 3 months ago

  • Related to Bug #90368: seo-extension: xml-sitemap refers for xsl-file to /typo3/ folder in frontend context added
Actions #2

Updated by Georg Ringer 3 months ago

  • Related to Feature #88147: Configurable path to Resources/Public/CSS/Sitemap.xsl in SEO module added
Actions #3

Updated by Georg Ringer 3 months ago

  • Status changed from New to Closed

as described in 88147 you can change the path to the directory.

with version 12 the path is changed again and it is in /_assets/984e6ee9829f85eb447bb6a36455204a/CSS/Sitemap.xsl which will be fine out of the box

Actions

Also available in: Atom PDF