Project

General

Profile

Actions

Bug #103115

closed

No backend.form equivalent for JavaScriptModules required in the site configuration

Added by Philipp Wrann 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Start date:
2024-02-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TL;DR:

Please add all "backend.form" tagged importmap entries in the initial page load of the site configuration module.
See: https://talk.typo3.org/t/enablerichtext-flag-not-working-on-site-language-field-after-update-to-typo3-12/5172/3

Details:

In TYPO3 V11 it was possible to use a CKEditor instance in the site_language record. After migrating to V12 this will only work, if you force a CKEditor instance in the site record itself. The reason is the migration to ES Modules and the usage of importmaps which can only be defined once in the initial page load. This is by design and therefore you need to define all possible aliases at once. In case of the TCEForms engine the problem has been dealt with by adding the "backend.form" tag and defining all module aliases with that tag in the initial page load. But there is no equivalent for the site configuration.

I don't see a reason why CKEditor should not be possible in the site configuration. In my case i maintain some consent texts via the site configuration. Those texts require the possibility of linking, so a CKEditor is required because those settings are meant to be changed by members of our support staff.

If TYPO3 decides to limit the site configuration even more than it already was, i will need to migrate all kinds of settings to the root page records.

Hence my request: Please either load all "backend.forms" importmap entries in the site configuration module or introduce a new tag for the site configuration module.

I added this to the "Bug" tracker because it worked in V11 and it is weird, that i can make this work by adding a dummy RTE field for the site record. This seems more like a bug than a intended limitation.

Actions #1

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83000

Actions #2

Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83000

Actions #3

Updated by Philipp Wrann 4 months ago

When manually applying the changes in V12 it works!

Actions #4

Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83017

Actions #5

Updated by Andreas Fernandez 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF