Bug #14329

RTE breaking links to pages on local domain

Added by old_zorbital about 17 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2004-09-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Our site runs typo3 along with static pages in the same domain. When we link to non-typo3 pages on our site from within the RTE, the links become translated and stored in the database in a broken form that causes them not to display when viewed on the front end. For example, if I am working from site.example.com, and I post a link in the RTE to http://site.example.com/some/place/ it gets stored in the DB as <LINK some/place>http://site.example.com/some/place/&lt;/LINK> Notice that it doesnt even store the leading slash. I belive that if a page is aliased within typo3 the frontend link will appear properly, but when a link is to a static page that typo3 has no way of knowing about, the frontend link text is simply not linked to anything. So far, the only way we have been able to link to other pages in our site are to create "External URL" stub pages in typo3 and link to them.

This error still exists in 3.1-rc2 as well as 3.6.2 which we are running.

RTE: HTML-Area (typo3 >=3.6)
AliasPro Extention

(issue imported from #M376)

#1

Updated by Lyle E about 17 years ago

The poster meant to indicate that the error still exists with 3.7.1-rc2 as opposed to 3.1-rc2.

#2

Updated by Gregor Kaczmarczyk over 16 years ago

Just discovered the same bug on a 3.7.0 install after migration from 3.5.0.
It´s not possible to link to a external link using the website domain in the link ;)
can this be fixed? was it already fixed in CVS for 3.8.0?

does anybody know which files are involwed in checking links in RTE?

#3

Updated by Mathias Schreiber over 15 years ago

Closed due to general Bugtracker Cleanup.

TYPO3 Version 3.6.2 will no longer be supported.

Also available in: Atom PDF