Bug #14336

Database analyzer gives stupid Alter statements by comparing existing schema with database.sql

Added by Sven Wilhelm about 17 years ago. Updated about 15 years ago.

Status:
Closed
Priority:
Should have
Category:
Install Tool
Target version:
-
Start date:
2004-09-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.7.0RC2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a database schema exists (even if you have just dumped the database.sql file into the database) the compare with database.sql function offers alter statements that do not really differ from the exisiting schema.

Examples below:
Offers:
ALTER TABLE be_groups CHANGE uid uid int(11) unsigned NOT NULL auto_increment;
Current Schema:
Current value: int(11) unsigned DEFAULT '0' NOT NULL auto_increment
Offers:
ALTER TABLE be_groups CHANGE pid pid int(11) unsigned NOT NULL default '0';
Current Schema:
Current value: int(11) unsigned DEFAULT '0' NOT NULL

So it would be just a no operation.

Use an existing Typo3-Database-Schema and upgrade to 3.7rc?

(issue imported from #M384)


Related issues

Is duplicate of TYPO3 Core - Bug #14139: Install tool is incapable of comparing modern database dumpsClosedIngmar Schlecht2004-05-03

Actions
#1

Updated by Ingmar Schlecht about 17 years ago

This is a duplicate of #0000055.
Wolfgang Klinger has already written a patch, but it has not been authorized by Kasper yet.

Also available in: Atom PDF