Bug #14601

XHTML compliance of GMENU with onmouseover images

Added by Ernesto Baschny almost 15 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2005-03-08
Due date:
% Done:

0%

TYPO3 Version:
3.8.0-dev
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently a GMENU is transformed into links like:

<a onmouseover="over('...')" onmouseout="over('...')" href="..."><img name="..." .../></a>

The problem is the "name" attribute in the <img> tag, which is not allowed in XHTML 1.1. The proper replacement is the "id" attribute.

But replacing this breaks the over() and out() JavaScript functions (at least on IE).

So the solution is to:

- use 'id' instead of 'name' in tslib/class.tslib_menu.php
- fallback to getElementById(name) in the generated javascript, so that IE will find the img we are referring to

Attached is a patch on the current (8.3.2005) CVS HEAD with these changes.

(issue imported from #M874)

0000874-TYPO3core-xhtml-id-instead-of-name.patch View (3.68 KB) Administrator Admin, 2005-03-08 13:11

History

#1 Updated by Sacha Vorbeck about 14 years ago

keyword:accessibility

#2 Updated by Sebastian Kurfuerst about 14 years ago

I think I will take care of this. the patch looks good to me, will try to get it into CVS.
Greets, Sebastian

#3 Updated by Sebastian Kurfuerst about 14 years ago

fixed in CVS.

Also available in: Atom PDF