Bug #14929

Need to set config.noPageTitle to 2 to make it work

Added by Steven Bagshaw about 14 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2005-08-18
Due date:
% Done:

0%

TYPO3 Version:
3.8.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

http://typo3.org/documentation/document-library/doc_core_tsref/quot_CONFIG_quot/ reports that config.noPageTitle is a boolean field. However, to get it to work as intended I needed to use config.noPageTitle = 2

I don't know if the code or the documentation is wrong, but line 616 of tslib_pagegen.php checks for !== 2

The effect is if I have TS in my template like

config.noPageTitle = 1
page.headerData.20 = TEXT
page.headerData.20.field = subtitle // title
page.headerData.20.wrap = <title>My Website Title: |</title>

then I end up with two <TITLE> tags in the <HEAD>

If I change to

config.noPageTitle = 2

then it's OK. But the documentation isn't enlightening on what the value 1 would do, if anything.
(issue imported from #M1382)

History

#1 Updated by Michael Stucki about 14 years ago

You are right, this is implemented but not yet documented. The reason for this is that TSref for 3.8.0 still needs to be released. See below for the new description:

--- cut ---
noPageTitle, int

If you only want to have the sitename (from the template record) in your
<title> tag, set this to 1. If the value is 2 then the <title> tag is not
printed at all.
Please take note that this tag is required for XHTML compliant output, so you
should only disable this tag if you generate it manually already.

Default value: 0
--- cut ---

Also available in: Atom PDF