Feature #15166

typolink ATagParams should have stdWrap properties

Added by Sacha Vorbeck about 16 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2005-10-31
Due date:
% Done:

0%

Estimated time:
PHP Version:
4
Tags:
Complexity:
Sprint Focus:

Description

Currently, ATagParams only takes a string as value. If you`d like to add a background-image dynamically (e. g. in a flexible content element), you can`t create the style property with an IMG_RESOURCE object:

<a class="thumb" style="background: #fff url(/uploads/tx_templavoila/test.gif) no-repeat 50% 50%;" href="#"></a>

That`s why I think it would be a good idea to have stdWrap properties for typolink ATagParams.

Below is an example how a CSS-background image for a link could be created.

ATagParams.cObject = COA
ATagParams.cObject {
10 = IMG_RESOURCE
10 {
file {
import = uploads/tx_templavoila/
import.current = 1
import.listNum = 0
maxW = 120
}
stdWrap.wrap = style="background: #fff url(/|) no-repeat 50% 50%;"
}
}
(issue imported from #M1749)


Related issues

Is duplicate of TYPO3 Core - Feature #14886: stdWrap for TMENUITEM's ATagParamsClosedSebastian Kurfuerst2005-07-29

Actions
#1

Updated by Sacha Vorbeck about 16 years ago

Ernesto submitted a patch for this problem a few minutes after I submitted this bug: http://bugs.typo3.org/view.php?id=1320
Magic

#2

Updated by Ingo Renner over 13 years ago

has been fixed

Also available in: Atom PDF